Blog Magentiamo

Installazione Magento: I requisiti di sistema

Per poter installare Magento Community Edition, hai bisogno dei requisiti che indichiamo in questa pagina.

Se invece stai cercando una guida per l'installazione ti invito a leggere anche:

[column size="one-half"]

Sistemi Operativi

  • GNU/Linux x86, x86-64

[/column]

[column size="one-half" last="true"]

Web Server supportati

  • Apache 1.3.x
  • Apache 2.0.x
  • Apache 2.2.x

[/column]


[column size="one-half"]

Browser Supportati

  • Microsoft Internet Explorer 6 e superiori
  • Mozilla Firefox 2.0 e superiori
  • Apple Safari 2.x
  • Google Chrome
  • E' richiesto il plugin per Adobe Flash

[/column]

[column size="one-half" last="true"]

MySQL

  • 4.1.20 o superiore
  • InnoDB storage engine

[/column]


[column size="one-half"]

SSL

  • Se si fa uso del protocollo HTTPS per l'amministrazione, è richiesto un certificato SSL. Certificati SSL self-signed non sono supportati.

[/column]

[column size="one-half" last="true"]

Server - Hosting - Setup

  • Possibilità di eseguire cronjob con PHP 5
  • Possibilità di fare l'override di opzioni mediante file .htaccess

Se per caso ancora non hai un server sicuro, veloce e ottimizzato per Magento dai un'occhiata al servizio di Hosting di Magentiamo.

[/column]


PHP

  • 5.2.x
  • Estensioni richieste:
    • PDO_MySQL
    • simplexml
    • mcrypt
    • hash
    • GD
    • DOM
    • iconv
    • curl
    • SOAP (per l'uso dei web service)
  • Safe_mode off
  • Memory_limit non inferiore a 256Mb (preferibilmente 512)